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Purpose/Objective: 
To classify, delineate, and digitize boundaries for key estuarine habitats using high resolution 
infrared aerial photographs and spatial software (ERDAS Imagine and ESRI ArcGIS).  When 
repeated over time, changes to estuarine habitats can be quantified.  Habitat and community 
composition data collected during vegetation surveys, as well as personal site knowledge can be 
used for ground-truthing and refinement of the spatial extent of each habitat classification. 
 

These methods were written by Ben Gustafson (USGS) and applied to the Nisqually Aug 8th, 2010 

aerial imagery, but the same general steps can be used to classify any imagery. 

 

These pages provide detailed information on the 

following: 

Image Preparation 
Unsupervised Classification  
Supervised Classification 
Ground Truthing 
Classification Smoothing 
 
Image Preparation 
Source Information 
Masking 
Resampling 
 
Source Information: 
Company Name: Bergman Photographic Services 
Acquisition Date: August 8th, 2010 
Time: unknown 
Altitude: unknown 
Scale: unknown 
Camera: unknown 
Focal Length: unknown 
Film/Digital: unknown 
 
All images were received as 4-band .tif files with .823 x .823 
foot pixel resolution.  Individual tiles were provided as well as 
a mosaic.   
 
Masking:  
High spectral variability across an image will likely produce 
class confusion in the output file.  One way to help reduce this 
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is to limit the number of pixels being considered during the classification process.  We can do this 
by first creating a polygon mask that overlaps only the areas we are interested in classifying.  

1. In ArcCatalog, create a new polygon shapefile or feature class with the same projection as 

the imagery you want to mask. 

2. Start a new ArcMap session and add the mosaic and the masking polygon you created. 

3. Create a polygon that covers the areas that you would like to include.   

4. Open the Extract by Mask tool (ArcToolbox > Spatial Analyst Tools > Extraction > Extract by 

Mask).   NOTE: This tool requires the Spatial Analyst Extension to be turned on (Tools > 

Extensions > Spatial Analyst Checkbox). 

5. Fill in the fields in the dialog box using the mosaic raster, your masking polygon, and an 

output raster name/location.  NOTE: In order to retain all four bands in your output raster, 

you will need to choose the input mosaic raster file location from disk rather than the layer 

in the drop-down box.   Using the layer name in the drop-down will result in a 3-band 

raster. 

 

Click OK.  

 

 
 

6. You may need to add the output raster to the 

map.  It should appear as if were clipped along 

the boundaries of the masking polygon you 

created. 

Resampling: Another way to help reduce class 

confusion and make more spatially consistent classes is 

to resample high resolution imagery to a courser 

resolution (theoretically, fewer pixels should reduce 

spectral variability).  However, before you choose a size 

to resample to, you need to determine your Minimum 

Mapping Unit (MMU).  This will be the size of the 
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smallest feature you wish to capture in the classification.  For the Nisqually imagery, we’ve decided 

our MMU will be the same as the vegetation surveys conducted in the restoration area: 0.5m x 0.5m. 

1. Open the Resample tool (ArcToolbox > Data Management Tools > Raster > Raster 

Processing > Resample).   

2. Fill out the fields in the Resample dialog box.  In this case, we are resampling from 0.822906 

feet to 1.64041 feet (.5 m = 1.64041 feet) so adjust the Output Cell Size value accordingly.  

Remember that the unit of measurement will be the same as the default unit of 

measurement of the raster’s projection.  Also, we will choose Cubic convolution as the 

Resampling Technique since satellite and aerial imagery are continuous data.  NOTE: In 

order to retain all four bands in your output raster, you will need to choose the input mosaic 

raster file location from disk rather than the layer in the drop-down box.   Using the layer 

name in the drop-down will result in a 3-band raster. 

 

Click OK. 

 

 

3. The output resampled raster should have the cell size you specified.  To check this, add the 
file to your map, right-click on it in the table of contents and choose Properties.   On the 
Source tab, look for the Cellsize (X,Y) property and the associated value. 
 

Unsupervised Classification:  
One method of creating a landcover classification is to let Erdas Imagine group the image pixels into 
categories automatically with only a few parameters.  Although this method can produce poor 
results, it can provide you with an idea of which classes are being easily confused and you can then 
put more focus on those areas in the supervised classification.  If your imagery contains a high 
contrast between the landcover types you would like to classify, the results of the unsupervised 
classification may be sufficient for your needs (or close enough to manually recode confused areas). 
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1. In Erdas Imagine, open the masked, 

resampled mosaic you created in the viewer.  

2. On the main Erdas Imagine toolbar (not the 

viewer toolbar), click the Classifier button, 

then click the Unsupervised Classification 

button on the Classification menu that 

appears. 

3. In the Unsupervised Classification dialog 

box, fill out the fields for the input raster, the 

output cluster layer (the output raster), and 

the output signature file.   

4. Clustering Options: A couple of these values 

may need to be determined through a little 

trial and error.  To begin with, make sure 

Initialize from Statistics is selected with the 

Number of Classes set to 15 (we are looking 

for classes that fall into water, mudflat, trees, 

lowland vegetation, bare earth, and 

impervious, but some of these could easily be lumped together so we ask for more classes to 

determine this manually).  The Initializing Options should be set to Diagonal Axis and 2 Std. 

Deviations.  The Color Scheme Options should be set to Approximate True Color. 

5. Processing Options: Again, these values may require some trial and error to determine the 

best settings.  To start, we’ll set it to run 20 iterations with a 0.980 Convergence Threshold.  

Then click OK.  You should see the Process List appear with a progress meter for each 

iteration.  This process can take several minutes or longer depending on the number of 

classes, iterations, and the convergence threshold specified. 

6. Add the output classification raster you created to the Viewer.  You’ll notice that the colors 

used for the classes are similar to those of the mosaic.  We will want to change these so we 

can analyze how accurate the classes are.  Choose Raster > Attributes form the Viewer 

window to open the Raster Attribute Editor for the classification. 

7. In the Raster Attribute Editor dialog, change the opacity of all of the items in the list to 0 

except but one class.  Highlight the one class left with an opacity of 1 by clicking on its Row 

number, then click on the color for that class.  Choose yellow for the color.  In the Viewer, 

you should see only the pixels associated with that class in yellow over the mosaic raster. 
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8. Now we want to try to determine which class the yellow 

pixels correspond to on the image.  Zoom into an area 

on the image where the yellow pixels are present.  

Choose View > Arrange Layers from the Viewer menu to 

open the Arrange Layers window.  Click on the 

classification layer to drop it below the mosaic layer 

and click Apply.  Then click on the mosaic layer to drop 

it below the classification layer and click Apply.  You 

can do this repeatedly to toggle one layer over the other 

and compare the class with the image and determine 

the landcover type it is associated with. 

 

Alternately, you can also choose Utility > Swipe from 

the Viewer menu to open up the Swipe dialog.  This 

allows you to swipe back and forth between the two 

layers and compare them that way. 

9. Evaluate the class throughout the image.  If the pixels appear to correspond to a single class 

type throughout, you can enter that as the class name in the Raster Attribute Editor and 

assign an appropriate color.  If the class seems to correspond to multiple landcover types, 

you can enter “confused” as the class name or more specific information such as “bare earth 

mudflat confused.”   

 

 

10. Change the opacity for the class you just evaluated to 0 and set a different one to 1.  

Evaluate this class using the method described above.  Repeat this process for each class 

until you have determined the landcover type (or class confusion) for all of them.  Be sure to 

save your changes to the attributes.  NOTE: If the accuracy of the classes appear to be 

consistently wrong, you can go back and re-run the unsupervised classification with 

different parameters.  For example, you might consider adding more classes to see if Erdas 

Imagine can find more spectral separation and hopefully reduce the amount of confusion.   
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11. Using the unsupervised classification settings 

above, it appears that Mudflat, Bare Earth, and 

Impervious features are consistently confused.  

These are areas that we now know we will need to 

focus on next in a Supervised Classification.    

12. NOTE: Another method you can use to try to 
reduce class confusion is to run an unsupervised 
classification on the confused classes only.  You can 
do this by creating an AOI (Area of Interest) file of 
the confused classes and adding it to the 
unsupervised classification settings, telling Erdas 
Imagine to create a subset that looks only at the 
pixels of the confused classes.  The output 
signature file may have better separation among those areas that were initially confused.  
This signature file can then be appended to the initial one you created to create a cleaner 
classification. 
 
In the case of this imagery, creating an AOI subset only produced a couple of cleaner classes, 
so we will move on to the Supervised Classification. 

 
Supervised Classification:  
This method requires the user to manually create training sites throughout the imagery for each 
class.  Erdas Imagine uses these training sites as representative spectral signatures to determine 
the classes for the rest of the image.  Although this method is the most time-consuming, it can also 
produce the best overall results in the output file. 
 

1. In Erdas Imagine, open the resampled, masked, mosaic you created in the viewer.  

2. On the main Erdas Imagine toolbar, click the Classifier button, then click the Signature 

Editor button on the Classification menu that appears.  You should see the Signature Editor 

window appear. 

 

 

3. Open the AOI tools by choosing AOI > Tools on the Viewer menu. 

4. Zoom in to area of the imagery that has an example one of the landcover types you are 

interested in classifying.   
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5. From the AOI toolbar, choose the Create Polygon AOI   tool.  

6. On the image, draw a polygon large enough to overlap several pixels of a single landcover 

type.  Double-click to finish the AOI polygon. 

7. On the Signature Editor window, click on the Create New Signature(s) from AOI   

button.  This adds the signature to the list based on the pixels within the AOI polygon you 

created in the image.  Edit the Signature name to reflect the landcover type for which it 

corresponds. 

8. Gather several training sites per landcover type (preferably 10 to 30 each).  The goal is to 

capture as much of the spectral variability within each class as possible.  If there are 

landcover types that you know will have spectral similarities, make extra training sites for 

each.  Make a few shadow classes to try and separate between shadow types (shadow trees, 

shadow impervious, etc.).  Be sure to save the signature file often. 
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9. Once you have completed the training sites, 

the signature file can be used to create a 

supervised classification.  On the 

Classification menu, click the Supervised 

Classification button.  In the dialog window 

that appears, select the mosaic image and 

the signature file you created for the inputs.  

Designate and output file name and leave the 

other default settings (None for Non-

parametric Rule and Maximum Likelihood 

for the Parametric Rule).  Click OK. 

10. Add the output raster to the Viewer display 

and open the Raster Attribute Editor (Raster 

> Attributes).  

11. In the Raster Attribute Editor dialog, change 

the opacity of all of the items in the list to 0 

except but one class.  Highlight the class 

with the opacity of 1 by clicking on its Row 

number, then click on the color for that class.  Choose yellow for the color.  In the Viewer, 

you should see only the pixels associated with that class in yellow over the mosaic raster. 

12. Evaluate the accuracy of the class throughout the image.  If the class appears to be classified 

correctly, give it an appropriate color and note that it is good.  If the class seems to 

correspond to multiple landcover types, you can enter “confused” after the class name or 

more specific information such as “Mudflat 13 confused some Impervious.”   
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13. Change the opacity for the class you just evaluated 

to 0 and set a different one to 1.  Evaluate this 

class using the method described above.  Repeat 

this process for each class until you have 

determined how well the image was classified. It is 

likely that you will have some classes that have 

poor separation, such as shadow areas. 

 

In the Nisqually imagery, classification improved 

in some areas, but there was still a lot of confusion 

between mudflat and impervious features.  

Environmental conditions at the time that the 

imagery was acquired (position of the sun, high 

reflectance, cloud cover, etc.) can cause some 

landcover types to have similar spectral values.  In order to get a high quality classification, 

you will need to refine the output. 

14. One way to improve the output of the supervised classification is to add more training sites 

to the signature file and re-run the classification.  However, if you already have a large 

number of training sites per landcover type, the output may not improve. 

 

Another option is to manually recode areas of confusion.  This is especially good for areas 

with only a slight confusion.  For example, in the masked version of the Nisqually image, 

there are very few impervious features that exist.  By going back to the Mudflat classes that 

had some Impervious pixels, we can go back and select those pixels and recode them as 

Impervious.  This will in turn remove the confused Impervious cells from the other classes, 

making the classification more accurate. 

15. Set the opacity of one of the classes with slight confusion to 1.  Do the same for a good class 

that is same type as the one with the slight confusion (not the predominate class type).  For 

example, I am starting with a Mudflat class with slight Impervious confusion and a good 

Impervious class. 

16. Zoom into an area with where class confusion is occurring.  In this case, I am zooming into a 

building that has some mudflat class pixels over it.  This is the area that you are going to 

recode to match the non-confused class.  Choose AOI > Tools to bring up the AOI toolbar and 

Raster > Tools to bring up the Raster toolbar. 

17. From the AOI toolbar, click on the Region Grow AOI tool.  Choose AOI > Seed Properties 

from the Viewer menu.  In the Region Growing Properties dialog box, set the Area to a very 

high number, such as 1,000,000.  This will allow the Region Grow AOI tool to select a larger 

number of connected pixels at a time.  Close the Region Growing Properties dialog and then 

click on an area of confused pixels that you want to reclassify.   The Region Grow AOI should 

produce a selection of all the adjacent or connected pixels from where you clicked that are 
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the same class. For large, contiguous areas (such as roads or structures) you can also use 

the Create Polygon AOI  tool to delineate sections to recode.   

18. Once you’ve created an AOI selection, click on 

the Fill Area  tool on the Raster toolbar.  In 

the Area Fill dialog that opens, change the Fill 

With field to the same number as the Row of the 

class you want to reclassify the selected area as.  

In this example, I am setting the value to match 

the good Impervious class.  Click Apply.  You can 

leave this dialog open and make another 

selection with the Region Grow AOI or Create 

Polygon AOI tools and repeat this process until 

you have changed all the confused areas that you 

want to reclassify.  If this eliminates the class confusion, rename the class in the Raster 

Attribute Editor to reflect this.  Repeat this process for any other slightly confused classes. 
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Cleaning up the classification can take a considerable amount of time.  If some of the 

spectral values are too similar between classes, it may be impossible to make a perfect 

classification.  You will need to decide at what point the classification has reached an 

acceptable level of accuracy. 

19. Once you have finished cleaning up the classification, you will probably want to merge the 

classes that are of the same type.  You can do this in Erdas Imagine using the Recode tool 

(Interpreter > GIS Analysis > Recode), however the Reclassify tool in ArcMap seems to 

provide a better output. 

20. Start ArcMap and add your classification to the map.  Write down your final class types 

(Water, Vegetation, Impervious, etc.) and assign a number value to each (1, 2, 3, etc.).   

21. Open the Reclassify tool (ArcToolbox > Spatial Analyst Tools > Reclass > Reclassify).  In the 

dialog window, set the classification as the input raster and the Reclass field to Value.   

 

In the Reclassification fields, change each of the New values to match the class types you 

wrote down above.  This can be a little tricky, so I find it helps to have the attribute window 

of the raster open at the same time to refer to  (you can also add a Reclass field to the 

attribute table and put the new values there first for reference). 

 

 

22. Once the reclassified image has been created, right click on it in the Table of Contents and 
choose Properties.  On the Symbology tab, set the Show field to Unique Values and the Value 
Field to VALUE.  You should see a Count column in the main section for each class value.  
This is the count of pixels that comprise each of the classes.  We can use this to find the area 
of area of each class type by multiplying the count value by the area of each pixel (the count 
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value is also in the attribute table).  In the case of the August 2010 Nisqually imagery, the 
pixel area is: 1.64041 x 1.64041 = 2.6909 square feet. 

 
Ground-Truthing:  
Classification accuracy is subject to the interpretation of the analyst and the settings used to 
calculate classes.  Ideally, classifications should be checked against the real ground conditions.  
Random areas, or areas where accuracy is most important, should be inspected on the ground 
and compared to the classification values.  This is especially important in situations where more 
specific landcover types are being classified, such as different kinds of vegetation.   Ground-
truthing should be done as close to the time of image acquisition as possible. 
 
OPTIONAL 
Classification Smoothing:   
To reduce salt and pepper effects and improve the overall appearance of your images, you can 
run a majority filter on your classifications.  This will use a moving neighborhood window to 
smooth out the cell values throughout the image. 
 

1. From the main Erdas Imagine menu, choose Interpreter > GIS Analysis > Neighborhood. 
 

2. In the Neighborhood Functions window, set the input and output file names.  Choose a 
neighborhood size in the Neighborhood Definition section (3x3, 5x5, or 7x7).  The larger 
the window size, the more smoothing that will occur.  Make sure the Function is set to 
Majority and click OK. 
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3. The resulting 

output raster 

should contain 

more solid 

landcover 

types 

throughout the 

image.  Keep in 

mind that 

although the 

image may 

appear cleaner, 

you are 

probably 

lowering the 

overall 

accuracy of 

your 

classification. 

 

 


